/[thuban]/branches/WIP-pyshapelib-bramz/debian/rules
ViewVC logotype

Annotation of /branches/WIP-pyshapelib-bramz/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1829 - (hide annotations)
Thu Oct 16 13:14:42 2003 UTC (21 years, 4 months ago) by silke
Original Path: trunk/thuban/debian/rules
File size: 1188 byte(s)
New directory with configuration files for building a thuban deb-package.

1 silke 1829 #!/usr/bin/make -f
2     # Sample debian/rules that uses debhelper.
3     # GNU copyright 1997 to 1999 by Joey Hess.
4    
5     # Uncomment this to turn on verbose mode.
6     #export DH_VERBOSE=1
7    
8     # This is the debhelper compatibility version to use.
9     export DH_COMPAT=4
10    
11     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
12     CFLAGS += -g
13     endif
14     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
15     INSTALL_PROGRAM += -s
16     endif
17    
18     build: build-stamp
19    
20     build-stamp:
21     dh_testdir
22    
23     python setup.py build
24    
25     touch build-stamp
26    
27     clean:
28     dh_testdir
29     dh_testroot
30     python setup.py clean
31     rm -f build-stamp
32     rm -rf build
33    
34     dh_clean
35    
36     install: build
37     dh_testdir
38     dh_testroot
39     dh_clean
40     dh_installdirs
41    
42     python setup.py install --prefix=/usr --no-compile --root=`pwd`/debian/thuban
43     ln -fs ../lib/thuban/thuban.py `pwd`/debian/thuban/usr/bin/thuban
44    
45     # Build architecture-dependent files here.
46     binary-arch: build install
47     dh_testdir
48     dh_testroot
49     dh_installdocs
50     dh_installexamples
51     dh_installmenu
52     dh_installmanpages
53     dh_installchangelogs
54     dh_link
55     dh_strip
56     dh_compress
57     dh_fixperms
58     dh_python
59     dh_installdeb
60     dh_shlibdeps
61     dh_gencontrol
62     dh_md5sums
63     dh_builddeb
64    
65     binary: binary-arch
66     .PHONY: build clean binary-arch binary install

Properties

Name Value
svn:eol-style native
svn:executable *
svn:keywords Author Date Id Revision

[email protected]
ViewVC Help
Powered by ViewVC 1.1.26