/[thuban]/branches/WIP-pyshapelib-bramz/debian/rules
ViewVC logotype

Annotation of /branches/WIP-pyshapelib-bramz/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2029 - (hide annotations)
Tue Dec 16 11:05:00 2003 UTC (21 years, 2 months ago) by silke
Original Path: trunk/thuban/debian/rules
File size: 1518 byte(s)
Some changes to ensure compliance of debian package with FHS when build
from tarball

1 silke 1829 #!/usr/bin/make -f
2     # Sample debian/rules that uses debhelper.
3     # GNU copyright 1997 to 1999 by Joey Hess.
4    
5     # Uncomment this to turn on verbose mode.
6     #export DH_VERBOSE=1
7    
8     # This is the debhelper compatibility version to use.
9     export DH_COMPAT=4
10    
11     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
12     CFLAGS += -g
13     endif
14     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
15     INSTALL_PROGRAM += -s
16     endif
17    
18     build: build-stamp
19    
20     build-stamp:
21     dh_testdir
22    
23 silke 2029 cp setup.py setup.py.orig
24     patch -p0 < debian/setup.py.patch
25 silke 1829 python setup.py build
26 silke 2029 mv setup.py.orig setup.py
27 silke 1829
28     touch build-stamp
29    
30     clean:
31     dh_testdir
32     dh_testroot
33 silke 2029 cp setup.py setup.py.orig
34     patch -p0 < debian/setup.py.patch
35 silke 1829 python setup.py clean
36 silke 2029 mv setup.py.orig setup.py
37 silke 1829 rm -f build-stamp
38     rm -rf build
39    
40     dh_clean
41    
42     install: build
43     dh_testdir
44     dh_testroot
45     dh_clean
46     dh_installdirs
47    
48 silke 2029 cp setup.py setup.py.orig
49     patch -p0 < debian/setup.py.patch
50 silke 1829 python setup.py install --prefix=/usr --no-compile --root=`pwd`/debian/thuban
51 silke 2029 mv setup.py.orig setup.py
52 silke 1829 ln -fs ../lib/thuban/thuban.py `pwd`/debian/thuban/usr/bin/thuban
53 silke 2029 cd debian/thuban; patch -p1 < ../bitmappath.patch; cd ../../
54 silke 1829
55     # Build architecture-dependent files here.
56     binary-arch: build install
57     dh_testdir
58     dh_testroot
59     dh_installdocs
60     dh_installexamples
61     dh_installmenu
62     dh_installmanpages
63     dh_installchangelogs
64     dh_link
65     dh_strip
66     dh_compress
67     dh_fixperms
68     dh_python
69     dh_installdeb
70     dh_shlibdeps
71     dh_gencontrol
72     dh_md5sums
73     dh_builddeb
74    
75     binary: binary-arch
76     .PHONY: build clean binary-arch binary install

Properties

Name Value
svn:eol-style native
svn:executable *
svn:keywords Author Date Id Revision

[email protected]
ViewVC Help
Powered by ViewVC 1.1.26