/[thuban]/branches/WIP-pyshapelib-bramz/debian/rules
ViewVC logotype

Annotation of /branches/WIP-pyshapelib-bramz/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2611 - (hide annotations)
Mon May 2 16:23:51 2005 UTC (19 years, 10 months ago) by jan
Original Path: trunk/thuban/debian/rules
File size: 1382 byte(s)
add --use-wx-python-swig-hack to the build command.
Thanks to Moritz Lennert for pointing this out.

1 silke 1829 #!/usr/bin/make -f
2     # Sample debian/rules that uses debhelper.
3     # GNU copyright 1997 to 1999 by Joey Hess.
4    
5     # Uncomment this to turn on verbose mode.
6     #export DH_VERBOSE=1
7    
8 silke 2095 include /usr/share/cdbs/1/rules/simple-patchsys.mk
9    
10 silke 1829 # This is the debhelper compatibility version to use.
11     export DH_COMPAT=4
12    
13     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
14     CFLAGS += -g
15     endif
16     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
17     INSTALL_PROGRAM += -s
18     endif
19    
20     build: build-stamp
21    
22     build-stamp:
23     dh_testdir
24    
25 jan 2611 python setup.py build_ext --use-wx-python-swig-hack build
26 silke 2095 # Multi-language support:
27     cd po; make mo
28 silke 1829 touch build-stamp
29    
30 silke 2095 clean::
31 silke 1829 dh_testdir
32     dh_testroot
33     python setup.py clean
34     rm -f build-stamp
35     rm -rf build
36    
37     dh_clean
38    
39     install: build
40     dh_testdir
41     dh_testroot
42     dh_clean
43     dh_installdirs
44    
45     python setup.py install --prefix=/usr --no-compile --root=`pwd`/debian/thuban
46     ln -fs ../lib/thuban/thuban.py `pwd`/debian/thuban/usr/bin/thuban
47 silke 2029 cd debian/thuban; patch -p1 < ../bitmappath.patch; cd ../../
48 silke 1829
49     # Build architecture-dependent files here.
50     binary-arch: build install
51     dh_testdir
52     dh_testroot
53     dh_installdocs
54     dh_installexamples
55     dh_installmenu
56     dh_installmanpages
57     dh_installchangelogs
58     dh_link
59     dh_strip
60     dh_compress
61     dh_fixperms
62     dh_python
63     dh_installdeb
64     dh_shlibdeps
65     dh_gencontrol
66     dh_md5sums
67     dh_builddeb
68    
69     binary: binary-arch
70     .PHONY: build clean binary-arch binary install

Properties

Name Value
svn:eol-style native
svn:executable *
svn:keywords Author Date Id Revision

[email protected]
ViewVC Help
Powered by ViewVC 1.1.26